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1 Product Overview

Introduction

In this section...

“Tuning Models with the Simulink® Response Optimization™ Software”
on page 1-2

“Tuning within Simulink® Models” on page 1-2

“Tuning within a SISO Design Task” on page 1-3

“Applications” on page 1-4

Tuning Models with the Simulink® Response
Optimization™ Software
You can tune and optimize control systems and physical systems using the
Simulink® Response Optimization™ graphical user interface (GUI). With this
product, you can directly tune response signals within Simulink® models
by inserting Signal Constraint blocks in your model. You can specify tuned
parameters, uncertain parameters and optimization settings in the Signal
Constraint block.

You can also tune responses of LTI systems by creating a SISO Design Task
and specifying constraints and design requirements for the system (requires
Control System Toolbox™ software).

Tuning within Simulink® Models
You can tune parameters within a nonlinear Simulink model to meet
time-domain performance requirements by graphically constraining signals
within a time-domain window or tracking and closely matching a reference
signal.

You can tune any number of Simulink variables including scalars, vectors, and
matrices. In addition, you can place uncertainty bounds on other variables
in the model for robust design. Simulink Response Optimization software
makes attaining performance objectives and optimizing tuned parameters an
intuitive and easy process.
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Introduction

You can directly tune Simulink models by including a special block, the Signal
Constraint block, in your Simulink diagram. To add a constraint on a signal,
connect the block to the signal in the model. Simulink Response Optimization
software automatically converts time-domain constraints into a constrained
optimization problem and then solves the problem using optimization routines
taken from Optimization Toolbox™ or Genetic Algorithm and Direct Search
Toolbox™ software. The constrained optimization problem iteratively calls for
simulations of the Simulink system, compares the results of the simulations
with the constraint objectives, and uses gradient methods to adjust tuned
parameters to better meet the objectives.

Two additional blocks, CRMS and DRMS, compute the continuous and
discrete cumulative root mean square values of signals. Use them with the
Signal Constraint block to optimize the cumulative root mean square of
signals in your model.

Tuning within a SISO Design Task
When you have Control System Toolbox software installed, you can design
compensators for control systems by tuning compensator elements or
parameters within a SISO Design Task in the Control and Estimation Tools
Manager. You can tune any elements or parameters, such as poles, zeros, and
gains, within any compensators in the system to optimize the responses of
both open and closed loops.

Optimize the responses of systems in the SISO Design Task to meet both
time- and frequency-domain performance requirements by graphically
constraining signals:

• Add frequency-domain design requirements to plots such as root-locus,
Nichols, and Bode in the SISO Design Task graphical tuning editor called
SISO Design Tool.

• Add time-domain design requirements to plots such as step or impulse
response (when displayed within the LTI Viewer as part of a SISO Design
Task).

You can use response optimization within a SISO Design Task in the Control
and Estimation Tools Manager to tune both command-line LTI models as well
as Simulink models:

1-3



1 Product Overview

• Create an LTI model using the Control System Toolbox command-line
functions and use the sisotool function to create a SISO Design Task
for the model.

• Use a Simulink Compensator Design task (requires the Simulink® Control
Design™ software) to automatically analyze the model and then create a
SISO Design Task for a linearized version of the model. You can then use
the response optimization tools within the SISO Design Task to tune the
response of the linearized Simulink model.

When using response optimization within a SISO Design Task you cannot add
uncertainty to system parameters.

Applications
You can use Simulink Response Optimization software for a variety of
applications. Possible uses include

• Designing and optimizing control systems by tuning compensator elements
such as poles, zeros, and gains.

• Designing physical systems by adjusting parameters in your system. For
example, adjust the dimensions of physical devices such as robot arms or
hydraulic pistons, tune properties of materials such as thermal emissivity,
etc.

• Closely tracking a reference, or desired, signal (using the Signal Constraint
block only).

• Optimizing responses for systems that include physical actuation limits
and constraints on state/variable values.

• Minimizing the energy in a system by minimizing the root-mean-square
signal.

• Including uncertainty in your parameter values to take into account
imperfect knowledge of certain physical parameters in your model (using
the Signal Constraint block only).
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System Requirements

System Requirements
Simulink® Response Optimization™ software has the same system
requirements as MATLAB® technical computing software. Refer to the
MATLAB documentation for details. For a list of required and related products,
see Simulink Response Optimization product page on the MathWorks Web
site at http://www.mathworks.com/products/simresponse/.

Upgrading from the Nonlinear Control Design Blockset
Software

Simulink® Response Optimization™ software replaces the Nonlinear Control
Design Blockset software. For information on upgrading from the blockset,
refer to the Release Notes. In addition, the ncdupdate reference page has
detailed information on updating the blockset models.

1-5
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1 Product Overview

Using the Documentation

In this section...

“Expected Background” on page 1-6

“How to Use This Guide” on page 1-6

“Online Documentation” on page 1-7

Expected Background
Users of this guide should be familiar with dynamic systems design and
analysis, and have experience creating Simulink® models.

How to Use This Guide
To get started using Simulink® Response Optimization™ software,
read Chapter 2, “Response Optimization Tutorial” which introduces the main
product features and uses three simple examples to describe their use.

To use both time- and frequency-domain design requirements to
optimize the response of LTI systems in a SISO Design Task (requires Control
System Toolbox™ software), read “Frequency Domain Response Optimization
Example” on page 2-23.

To perform response optimization using functions, read Chapter 3,
“Response Optimization Using Functions”.

For advice on solving typical problems, read Chapter 4,
“Troubleshooting”.

If you are upgrading from the Nonlinear Control Design Blockset
software, read the Release Notes to learn about new features and how to
convert your blockset models for use with Simulink Response Optimization
software.
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Online Documentation
Further documentation is available online, including function and block
references, and detailed discussions on setting up and running a response
optimization.
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Response Optimization
Tutorial

Quick Start — Time-Domain
Response Optimization of Simulink®

Models (p. 2-2)

A brief outline of the response
optimization process using time
domain requirements for Simulink®

models

Quick Start — Mixed Time and
Frequency Domain Response
Optimization (p. 2-4)

A brief outline of the response
optimization process using both
time and frequency domain design
requirements

Simple Control Design Example
(p. 2-6)

An example that tunes a single
system parameter to optimize a
response signal

Frequency Domain Response
Optimization Example (p. 2-23)

An example that tunes a system so
that its dynamics meet frequency
domain requirements

Physical Modeling Example (p. 2-46) An example that tunes multiple
system parameters to optimize
multiple response signals



2 Response Optimization Tutorial

Quick Start — Time-Domain Response Optimization of
Simulink® Models

If you want to quickly get started using Simulink® Response Optimization™
features for time domain response optimization of Simulink® models, this
section summarizes the response optimization process:

1 Make a Simulink model of your (nonlinear) system and controller. Add
input signals (e.g., steps, ramps, observed data) for which you know what
the desired output should look like.

2 Attach a Signal Constraint block to the signals you want to constrain.
The Simulink Response Optimization library srolib contains the Signal
Constraint block. To open the library, just type srolib at the MATLAB®

prompt or select Simulink Response Optimization from the Simulink
Library Browser.

3 If the model’s parameters do not already exist in the MATLAB workspace,
initialize these parameters in the workspace with a best first guess.

4 Double-click each Signal Constraint block in your system to open the
Signal Constraint window for each constrained output. Choose a method
for constraining the response signal by selecting Enforce signal bounds
and/or Track reference signal at the bottom of the window.

5 Within the Signal Constraint window, constrain each signal by positioning
constraint bound segments and/or tracking a reference signal. You can
position constraint bound segments by clicking and dragging the segment
or right-clicking the segment and selecting Edit from the menu. Plot
reference signals by selecting Goals > Desired Response from the Signal
Constraint window and entering vectors of data for the reference signal.

6 Open the Tuned Parameters dialog box by selecting Optimization > Tuned
Parameters within a Signal Constraint window. Click the Add button to
add parameters to the list. Select a parameter in the list to specify initial
guesses and maximum and minimum values.

7 Optional: Open the Uncertain Parameters dialog box by selecting
Optimization > Uncertain Parameters within a Signal Constraint
window. Click the Add button to add parameters to the list. Choose a
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method and range for sampling the uncertain parameters and select which
responses to optimize.

8 Optional: Save the project, including constraints, tuned parameters,
uncertain parameters, and settings for optimization and simulation, to a
file, to the MATLAB workspace, or to the model workspace by selecting
File > Save. You can retrieve previously saved projects by selecting
File > Load. To automatically save and reload the project with the
Simulink model, select the check box at the bottom of the Save dialog box.
Note that when saving the project, you are saving the entire optimization
project, which might include several Signal Constraint blocks.

9 Click the Start button in the toolbar or select Start from the Optimization
menu to optimize the response signal by adjusting the tuned parameters.
The Optimization Progress window displays the new, optimized parameter
values.
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Quick Start — Mixed Time and Frequency Domain
Response Optimization

This section outlines the response optimization process for linear systems
within a SISO Design Task in the Control and Estimation Tools Manager
using both time and frequency domain design requirements:

1 Create and import a linear model into a SISO Design Task using one
of two methods:

• Create an LTI model of your system at the MATLAB® command line and
use the sisotool function to create a SISO Design Tool for the model.

• Create a Simulink® model and use a Simulink Compensator Design
Task (requires Simulink® Control Design™ software) to automatically
linearize the model and create a SISO Design Task for the linearized
model.

2 Optional: Within the SISO Design Task node of the Control and
Estimation Tools Manager, select the Architecture pane and then select a
control architecture for your system.

3 Use the Graphical Tuning pane within the SISO Design Task node
of the Control and Estimation Tools Manager to create any design plots
you want to use to design the response of the system, such as root-locus
diagrams, Bode plots, etc. Use the Analysis Plots pane to create any
analysis plots you want to use to view the system, such as step or impulse
response plots.

4 Within the Automated Tuning pane select Optimization based tuning
as the Design Method and then click the Optimize Compensators
button to create a Response Optimization task within the Control and
Estimation Tools Manager.

5 Within the Response Optimization node, select the Compensators
pane to select and configure the compensator elements you want to tune
during the response optimization. Note that when optimizing responses
in a SISO Design Task, you cannot add uncertainty to parameters or
compensator elements.
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6 Within the Design requirements pane of the Response Optimization
node, select the design requirements you want the system to satisfy. To
add a new design requirement to a design or analysis plot, click the Add
new design requirement button and then complete the New Design
Requirement dialog box.

7 Optional: To change the default optimization settings and configure them
for your problem, click the Optimization Options button within the
Optimization pane.

8 Click the Start Optimization button within the Response Optimization
node. The optimization progress results appear within the Optimization
pane. The Compensators pane contains the new, optimized compensator
element values.

9 Optional: There are several options to export and save the results of the
response optimization:

• To export the newly designed compensators to the MATLAB Workspace
or a MAT-file, select File > Workspace within the SISO Design Tool
graphical tuning window.

• To save the SISO Design task, including the Response Optimization
task, select File > Save within the Control and Estimation Tools
Manager.

• If you are designing compensators for a Simulink model, click the
Update Simulink Block Parameters button within the SISO Design
Task node to write the newly designed compensators to the Simulink
model.
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2 Response Optimization Tutorial

Simple Control Design Example

In this section...

“Introduction” on page 2-6

“Design Requirements” on page 2-6

“Simulink® Response Optimization™ Software Startup” on page 2-7

“Adjusting Constraints” on page 2-7

“Specifying Tuned Parameters” on page 2-11

“Running the Optimization” on page 2-13

“Tracking a Signal” on page 2-15

“Adding Uncertainty” on page 2-18

“Saving the Project” on page 2-21

Introduction
Time-domain response optimization of Simulink® models uses time-domain
constraint bounds to represent lower and upper bounds on response signals.
You can stretch, move, split, or open constraint bounds in a variety of ways
that are explained here and in the online documentation. In this example, you
will constrain a parameter to control a second order SISO system via integral
action, shown in the following diagram.

Design Requirements
Specifically, the integral gain (Kint) should ensure that the closed loop system
meets or exceeds the following performance specifications when you excite
the system with a unit step input:

• A maximum 10% overshoot
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Simple Control Design Example

• A maximum 10-second rise time

• A maximum 30-second settling time

Because of the actuator limits and system transport delay, standard linear
control design techniques may not yield reliable results.

Simulink® Response Optimization™ Software Startup
The Simulink model srotut1 contains the system shown in the previous
figure. Open the system by entering srotut1 at the MATLAB® prompt.

You do not need to remodel any of your present Simulink systems to use
Simulink® Response Optimization™ software. You need simply to

1 Attach a Signal Constraint block to all signals you want to constrain. In
srotut1, a Signal Constraint block (square block with a step response
icon) is attached to the plant output.

2 Add input signals to the system, for which you know what the output
should look like. In srotut1, the input is a step since the desired step
response characteristics of the system are known.

3 Change the model’s Stop time to the desired value. In srotut1, the step
response should settle within 30 seconds, so simulating for 50 seconds
allows the step to go to completion. Since optimization with Simulink
Response Optimization software calls for many simulations of the system,
you should make the simulation time as short as possible, but long enough
to show dynamics of interest. You can change the Start time and Stop
time through the Simulink Simulation Parameters dialog box by selecting
Simulation > Configuration Parameters.

Adjusting Constraints
To open the Simulink Response Optimization Signal Constraint window,
double-click the Signal Constraint block. The window, shown in the following
figure, contains an amplitude versus time axis with default upper and lower
constraint bounds. To optimize the tuned parameters so that the response
signal lies within the constraint bound segments, select the Enforce signal
bounds check box at the bottom of the window.
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The lower and upper constraint bounds define a channel within which the
signal response should lie. The default constraints effectively define a rise
time of 5 seconds and a settling time of 15 seconds. These bounds must
change to reflect the performance requirements proposed in the beginning of
this section. To adjust the rise time constraint, position the mouse over the
endpoint of the lower bound constraint that ends at 5 seconds. Press and hold
down the (left) mouse button. The arrow should turn to a hand symbol as
shown next.
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Simple Control Design Example

In this mode, you can change the time boundary between two constraints as
well as change the slope of constraints. While still holding the mouse button
down, drag the constraint boundary to the right. Release the mouse button
after positioning the boundary as close as possible to 10 seconds. You may
find it helpful to enable axis gridding while placing constraints. To turn axis
gridding on or off, right-click anywhere within the white space of the Signal
Constraint window and select Grid from the menu. If you need to precisely
place constraint-bound segments, use the Edit Design Requirement dialog box,
which appears when you right-click a constraint-bound segment and select
Edit from the menu. See the online documentation for more information on
the Edit Design Requirement dialog box. Alternatively, to ensure that the
constraint remains perfectly horizontal (or vertical), you can press and hold
down the Shift key while clicking and dragging the constraint segment. This
causes the constraint segment to snap to the horizontal (or vertical).

To adjust the overshoot constraint, press and hold the (left) mouse button
somewhere in the middle of the upper bound constraint bound segment that
extends from 0 to 15 seconds. Notice that the pointer becomes a four-way
arrow. In this mode, you can drag the entire constraint edge anywhere within
the axes. While still holding the mouse button down, drag the constraint until
its lower boundary is at a height of 1.1 as shown in the following figure.
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2 Response Optimization Tutorial

Finally, the settling time constraints require adjustment. Position the mouse
button on the right edge of the lower constraint edge extending from 10 to 15
seconds. Press and hold down the (left) mouse button and notice that the
constraint becomes selected and that the pointer changes to a hand symbol.
In this mode, you can stretch the end of the constraint or change its angle.
While still holding the mouse button down, drag the constraint so that
the settling-time constraint begins at 30 seconds. Adjust the upper bound
constraint so that it too defines a 30-second settling-time constraint. The
constraint figure should now look the one shown next.
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Simple Control Design Example

Alternatively, you could set the signal constraints using the Desired Response
dialog box by selecting Goals > Desired Response from the Signal
Constraint window. For more information on setting signal constraints, see
the online documentation.

Specifying Tuned Parameters
Before beginning the optimization, you must select the variables to be tuned.
Open the Tuned Parameters dialog box by selecting Optimization > Tuned
Parameters within the Signal Constraint window. Add the parameter Kint
to the Tuned parameters list by clicking the Add button. This opens the
Select Parameters dialog box with a list of all model parameters that are
currently in the workspace.
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Select Kint in this list and click OK. This adds Kint to the Tuned
parameters list as shown in the following figure.
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To display the optimization settings for this parameter, click Kint in the
Tuned parameters list. The settings appear under Optimization settings
on the right. To constrain Kint to be positive, enter 0 as the Minimum value.
For more information on the various tuned parameter settings, see the online
documentation.

Running the Optimization
After adjusting the constraint bounds in the Signal Constraint window and
specifying the tuned parameters using the Tuned Parameters dialog box,
you are ready to begin the optimization. You can start an optimization by
clicking the Start button in the Signal Constraint window or by selecting
Optimization > Start.

Simulink Response Optimization software automatically converts the
constraint bound data and tuned parameter information into a constrained
optimization problem that it solves using Optimization Toolbox™ or Genetic
Algorithm and Direct Search Toolbox™ functions. It attempts to satisfy
the constraints on the response signals by adjusting the tuned parameters.
The results of each iteration appear in the Optimization Progress window
shown in the following figure. The number of iterations necessary for the
optimization to converge or terminate, will depend on the initial guess for
the tuned parameters, the specific positioning of the constraints, and the
optimization settings.
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2 Response Optimization Tutorial

In this case the optimization converges after four iterations. For more
information about the results shown in the Optimization Progress window,
see the online documentation.

The Signal Constraint window, shown in the following figure, plots the
responses at each iteration.

The blue line shows the initial response and the black line shows the current,
or final, response. As you can see, the final response signal lies within the
constraint bounds.

The new value of the tuned parameter Kint appears in the Optimization
Progress window and is also changed in the MATLAB workspace. In this
case the new value of Kint is 0.1852
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Note The Gradient descent optimization algorithm may violate the
bounds on parameter values when it cannot satisfy the signal constraints
specified in the Signal Constraint block and the bounds on parameter values
simultaneously. To learn how to troubleshoot this problem, see the Chapter
4, “Troubleshooting” section.

Because of different numerical precision, the results of the optimization may
differ slightly across different platforms.

Tracking a Signal
In addition to constraining the signal by constraint bounds, you can constrain
the signal by requiring it to closely match a reference signal. To do this, select
the Track reference signal option at the bottom of the Signal Constraint
window. To enter the reference signal, select Goals > Desired Response.
This displays the Desired Response dialog box, as shown in the following
figure.

For this example, use the reference signal given by
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Enter time and amplitude vectors for the reference signal in the Desired
Response dialog box as shown in the previous figure, and then click OK. This
displays the following plot in the Signal Constraint window. Note, to remove
the plots of the optimized response signals, as was done in the figure, select
Plots > Clear Plots.

Before running the optimization, change the function tolerance to 0.01
within the Options dialog box. This ensures that the new objective function
meets the imposed tolerances. To do this, open the Options dialog box by
selecting Optimization > Optimization Options from the menu in the
Signal Constraint window and then change the Function tolerance value to
0.01 within the Optimization Options pane of the Options dialog box, as
shown in the following figure.
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To run the optimization, select Optimization > Start or click the Start
button on the toolbar in the Signal Constraint window. The results, shown
next, are similar to the previous ones when only constraint bounds were used.
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The Optimization Progress window shows the final value of Kint.

Before proceeding to the next section, make sure to clear the Track reference
signal check box at the bottom of the Signal Constraint window.

Adding Uncertainty
In your particular problem, you might not have a precise plant model. Instead
you might know what the nominal plant should be and have some idea of
the uncertainty inherent in various components of the plant. For example,
assume that the plant parameter zeta varies 5% about its nominal value
and w0 varies between 0.7 and 1.45.

When using a Signal Constraint block to optimize response, you can also
optimize response signals in the face of this uncertainty by specifying
uncertainty in parameter values. Note that you cannot add uncertainty to
parameters or compensator elements when optimizing responses in a SISO
Design Task.

Open the Uncertain Parameters dialog box by selecting
Optimization > Uncertain Parameters in the Signal Constraint
window. To add zeta and w0 as uncertain parameters, click the Add button,
which opens the Select Parameters dialog box. This dialog box contains all
parameters from the model that are currently in the workspace and are not
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selected as tuned parameters. Select zeta and w0 in this list, and then click
OK.

The parameters appear within the Uncertain Parameters dialog box with their
default uncertainty settings. Their nominal values are the current parameter
values, and the uncertainty range is 10% on either side of the nominal value.

Change the uncertainty ranges to those given previously: 0.95 to 1.05 for
zeta and 0.7 to 1.45 for w0. The Uncertain Parameters dialog box should now
look like that in the following figure.

2-19



2 Response Optimization Tutorial

In this example, the sampling method for uncertainty is Random (Monte
Carlo). The other choice is Grid in which case you would enter a vector of
sample values for each parameter instead of minimum and maximum values.
The number of samples indicates how many parameter value combinations to
use other than the nominal, minimum, and maximum values.

By default, the nominal response is optimized along with all responses
corresponding to combinations of minimum and maximum values of w0 and
zeta (five responses total). To speed up the optimization, you can optimize
the nominal response only. To include more uncertainty, you can optimize
all sample parameter values. Select which responses to optimize in the
Optimized responses section of the Uncertain Parameters dialog box. If
you choose not to optimize all uncertain responses, you can still use them
for analysis by plotting them in the Signal Constraint window after the
optimization. For more information on specifying uncertainty in your models,
see the online documentation.
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Click OK to save your uncertain parameter information, and then run the
optimization again.

The uncertain responses are plotted as dashed lines. This time, the
optimization does not find a feasible solution due to the uncertain response
signals violating the constraints as shown in the following figure.

To get the optimization to converge, you might try a different initial guess,
relax the constraints slightly, or change the uncertain parameter values.
If the uncertain response signals do not violate the constraints by a large
amount, the result might be acceptable for your design needs.

To turn off the uncertain response plots, right-click within the figure axes and
select Show > Uncertainty. Turn them back on again by repeating this step.
To clear all plots, right-click within the figure axes and select Clear plots.

Saving the Project
A response optimization project includes the constraints (from all Signal
Constraint windows in the model), tuned parameter settings, uncertain
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parameter settings, and settings for the optimization and simulation. After
creating a project, you can save it for later use.

To save this project, select File > Save in the Signal Constraint window. This
opens the Save Project dialog box as shown in the following figure.

You can save the project to either a MATLAB workspace variable, model
workspace variable, or a MAT-file. By selecting the Save and reload project
with Simulink model check box, the project will automatically reload when
you reopen the model. If the model cannot find the saved project when you
reopen it, it gives a warning.

For more information on saving and reloading projects, see the online
documentation.
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Frequency Domain Response Optimization Example

In this section...

“Introduction” on page 2-23

“Design Requirements” on page 2-23

“Creating an LTI Plant Model” on page 2-24

“Creating Design and Analysis Plots” on page 2-25

“Creating a Response Optimization Task” on page 2-28

“Selecting Tunable Compensator Elements” on page 2-30

“Adding Design Requirements” on page 2-31

“Optimizing the System’s Response” on page 2-40

“Creating and Displaying the Closed-Loop System” on page 2-43

Introduction
When you have Control System Toolbox™ software, you can place Simulink®

Response Optimization™ design requirements or constraints on plots in the
SISO Design Tool graphical tuning editor and analysis plots that are part
of a SISO Design Task. This allows you to include design requirements for
response optimization in the frequency-domain in addition to the time-domain.
This section guides you through an example using frequency-domain design
requirements to optimize the response of a system in the SISO Design Task.

You can specify frequency-domain design requirements to optimize response
signals for any model that you can design within a SISO Design Task:

• Command-line LTI models created with the Control System Toolbox
commands

• Simulink® models that have been linearized using Simulink® Control
Design™ software

Design Requirements
The example uses a linearized version of the srotut1 model from “Simple
Control Design Example” on page 2-6 and uses response optimization to
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design a compensator so that the closed loop system meets the following
design specifications when you excite the system with a unit step input:

• A maximum 30-second settling time

• A maximum 10% overshoot

• A maximum 10-second rise time

• A limit of ±0.7 on the actuator signal

Creating an LTI Plant Model
In the srotut1 model, the plant model is composed of a gain, a limited
integrator, a transfer function, and a transport delay.

You want to design the compensator for the open loop transfer function
of the linearized srotut1 model. The linearized srotut1 plant model is
composed of the gain, an unlimited integrator, the transfer function, and a
Padé approximation to the transport delay.

To create an open loop transfer function based on the linearized srotut1
model, enter the following commands:

w0 = 1;
zeta = 1;
Kint = 0.5;
Tdelay = 1;
[delayNum,delayDen] = pade(Tdelay,1);
integrator = tf(Kint,[1 0]);
transfer_fcn = tf(w0^2,[1 2*w0*zeta w0^2]);
delay_block = tf(delayNum,delayDen);
open_loopTF = integrator*transfer_fcn*delay_block;

Note It is also possible to directly linearize the Simulink model srotut1
using Simulink Control Design software.
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Creating Design and Analysis Plots
This example uses a root locus diagram to design the response of the open loop
transfer function, open_loopTF. To create a SISO Design Task, containing a
root-locus plot for the open loop transfer function, use the following command:

sisotool('rlocus',open_loopTF)

A SISO Design Task is created within the Control and Estimation Tools
Manager, as shown in the following figure.

The Control and Estimation Tools Manager is a graphical environment
for managing and performing tasks such as designing SISO systems. The
SISO Design Task node contains five panels that perform actions related to
designing SISO control systems. For more information, see “Using the SISO
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Design Task in the Controls & Estimation Tools Manager” in “Control System
Toolbox” documentation.

The Architecture pane, within the SISO Design Task node, lets you choose
the architecture for the control system you are designing. This example uses
the default architecture. In this system, the plant model, G, is the open loop
transfer function open_loopTF, the prefilter, F, and the sensor, H, are set to
1, and the compensator, C, is the compensator that will be designed using
response optimization methods.

The SISO Design Task also contains a root locus diagram in the SISO Design
Tool graphical tuning editor.
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In addition to the root-locus diagram, it is helpful to visualize the response of
the system with a step response plot. To add a step response:

1 Select the Analysis Plots pane with the SISO Design Task node of the
Control and Estimation Tool Manager.

2 Select Step for the Plot Type of Plot 1.

3 Under Contents of Plots, select the check box in column 1 for the response
Closed Loop r to y.
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A step response plot appears in an LTI Viewer. The plot shows the response
of the closed loop system from r (input to the prefilter, F) to y (output of the
plant model, G):

Creating a Response Optimization Task
There are several possible methods for designing a SISO system; this example
uses an automated approach involving response optimization methods. After
creating the design and analysis plots as discussed in “Creating Design and
Analysis Plots” on page 2-25, you are ready to start a response optimization
task to design the compensator.

To create a Simulink Response Optimization task:
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1 Select the Automated Tuning pane within the SISO Design Task node
in the Control and Estimation Tools Manager.

2 In the Automated Tuning pane, select Optimization based tuning as
the Design Method.

3 Click the Optimize Compensators button to create the Response
Optimization node under the SISO Design Task node in the tree browser
in the left pane of the Control and Estimation Tools Manager.

The Response Optimization node contains four panes as shown in the
next figure.

With the exception of the first pane, each corresponds to a step in the response
optimization process:
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• Overview: A schematic diagram of the response optimization process.

• Compensators: Select and configure the compensator elements that you
want to tune. See “Selecting Tunable Compensator Elements” on page 2-30.

• Design requirements: Select the design requirements that you want
the system to meet after tuning the compensator elements. See “Adding
Design Requirements” on page 2-31.

• Optimization: Configure optimization options and view the progress of
the response optimization. See “Optimizing the System’s Response” on
page 2-40.

Note When optimizing responses in a SISO Design Task, you cannot add
uncertainty to parameters or compensator elements.

Selecting Tunable Compensator Elements
You can tune elements or parameters within compensators in your system so
that the response of the system meets the design requirements you specify. To
specify the compensator elements to tune:

1 Select the Compensators pane within the Response Optimization node.

2 Within the Compensators pane, select the check boxes in the Optimize
column that correspond to the compensator elements you want to tune.

In this example, to tune the Gain in the compensator C, select the check
box next to this element, as shown in the following figure.
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Note Compensator elements or parameters cannot have uncertainty when
used with frequency-domain based response optimization.

Adding Design Requirements
You can use both frequency-domain and time-domain design requirements
to tune parameters in a control system. The Design requirements pane
within the Response Optimization node of the Control and Estimation
Tools Manager provides an interface to create new design requirements and
select those you want to use for a response optimization.
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This example uses the design specifications described in “Design
Requirements” on page 2-23. The following sections each create a new design
requirement to meet these specifications.

Settling Time Design Requirement
The first design specification for this example is to have a settling time of 30
seconds or less. This specification can be represented on a root-locus diagram
as a constraint on the real parts of the poles of the open loop system.

To add this design requirement:

1 Select the Design requirements pane within the Response
Optimization node of the Control and Estimation Tools Manager.

2 Click the Add new design requirement button. This opens the New
Design Requirement dialog box.

Within this dialog box you can specify new design requirements and add
them to a new or existing design or analysis plot.

3 Add a design requirement to the existing root-locus diagram:

a Select Pole/zero settling time from the Design requirement type
menu.

b Select Open-Loop L from the Requirement for response menu.

c Enter 30 seconds for the Settling time.

d Click OK.

A vertical line should appear on the root-locus diagram, as shown in the
following figure.
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Overshoot Design Requirement
The second design specification for this example is to have a percentage
overshoot of 10% or less. This specification is related to the damping ratio on
a root-locus diagram. In addition to adding a design requirement with the
Add new design requirement button, you can also right-click directly on
the design or analysis plots to add the requirement, as shown next.

To add this design requirement:
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1 Right-click anywhere within the white space of the root-locus diagram in
the SISO Design Tool window. Select Design Requirements > New to
open the New Design Requirement dialog box.

2 Select Percent overshoot as the Design requirement type and enter 10
as the Percent overshoot.

3 Click OK to add the design requirement to the root-locus diagram. The
design requirement appears as two lines radiating at an angle from the
origin, as shown in the following figure.

2-34



Frequency Domain Response Optimization Example

Rise Time Design Requirement
The third design specification for this example is to have a rise time of
10 seconds or less. This specification is related to a lower limit on a Bode
Magnitude diagram.

To add this design requirement:

1 Select the Graphical Tuning pane within the SISO Design Task node of
the Control and Estimation Tools Manager.

2 For Plot 2, set Plot Type to Open-Loop Bode.

3 Right-click anywhere within the white space of the open-loop bode diagram
in the SISO Design Tool window. Select Design Requirements > New to
open the New Design Requirement dialog box.

4 Create a design requirement representing the rise time and add it to the
new Bode plot:

a Select Lower gain limit from the Design requirement type menu.

b Enter 1e-2 to 0.17 for the Frequency range.

c Enter 0 to 0 for the Magnitude range.

d Click OK.

A Bode diagram appears within the SISO Design Tool window. The
magnitude plot of the Bode diagram includes a horizontal line representing
the design requirement, as shown in the following figure.
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Actuator Limit Design Requirement
The fourth design specification for this example is to limit the actuator signal
to within ±0.7. To add this design requirement:

1 Select the Design requirements pane within the Response
Optimization node of the Control and Estimation Tools Manager.

2 Click the Add new design requirement button to open the New Design
Requirement dialog box.
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3 Create a time-domain design requirement representing the upper limit on
the actuator signal, and add it to a new step response plot in the LTI Viewer:

a Select Step response upper amplitude limit from the Design
requirement type menu.

b Select Closed Loop r to u from the Requirement for response
menu.

c Enter 0 to 10 for the Time range.

d Enter 0.7 to 0.7 for the Amplitude range.

e Click OK. A second step response plot for the closed loop response from
r to u appears in the LTI Viewer. The plot contains a horizontal line
representing the upper limit on the actuator signal.

f To extend this limit for all times (to t=∞), right click on the black edge of
the design requirement, somewhere toward the right edge, and select
Extend to inf. The diagram should now appear as shown next.
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To add the corresponding design requirement for the lower limit on the
actuator signal:

1 Within the white space of the lower step response plot, right-click and select
Design Requirements > New to open the New Design Requirement
dialog box.

2 Create a time-domain design requirement representing the lower limit on
the actuator signal, and add it to the step response plot in the LTI Viewer:

a Select Step response lower amplitude limit from the Design
requirement type menu.

b Select Closed Loop r to u from the Requirement for response
menu.
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c Enter 0 to 10 for the Time range.

d Enter -0.7 to -0.7 for the Amplitude range.

e Click OK. The step response plot now contains a second horizontal line
representing the lower limit on the actuator signal.

f To extend this limit for all times (to t=∞), right-click in the yellow shaded
area and select Extend to inf. The diagram should now appear as
shown in the following figure.

Selecting the Design Requirements to Use During Response
Optimization
The design requirements give constraints on the dynamics of the system
and the values of response signals. The table lists all design requirements
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in the design and analysis plots. Select the check boxes next to the design
requirements you want to use in the response optimization. This example
uses all the current design requirements.

Optimizing the System’s Response
After selecting the compensator elements to tune and adding design
requirements for the response signals to satisfy, you are ready to being the
response optimization.

The Optimization pane within the Response Optimization node of the
Control and Estimation Tools Manager displays the progress of the response
optimization. The pane also contains options to configure the types of progress
information displayed during the optimization and options to configure the
optimization methods and algorithms.

To optimize the response of the system in this example, click the Start
Optimization button.

The Optimization pane displays the progress of the optimization, iteration
by iteration, as shown next. Termination messages from the optimization
algorithm and suggestions for improving convergence also appear here.
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The optimized signals in the design and analysis plots appear as follows:

2-41



2 Response Optimization Tutorial

2-42



Frequency Domain Response Optimization Example

Creating and Displaying the Closed-Loop System
After designing a compensator by optimizing the response of the system, you
can create export the compensator to the MATLAB® workspace and create a
model of the full closed-loop system.

1 Within the SISO Design Tool window, select File > Export to open the
SISO Tool Export dialog box.

2 Select the compensator you designed, Compensator C, and then click
the Export to Workspace button.
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At the command line, enter the following command to create the closed-loop
system, CL, from the open-loop transfer function, open_loopTF, and the
compensator, C:

CL=feedback(open_loopTF,C);

This returns the following model:

Zero/pole/gain:
-0.5 (s-2)

-------------------------------------------------
(s^2 + 0.4244s + 0.1079) (s^2 + 3.576s + 3.375)

To create a step response plot of the closed loop system, enter the following
command:

step(CL);

This produces the following figure:
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Physical Modeling Example

In this section...

“Introduction” on page 2-46

“Design Requirements” on page 2-46

“Opening the Hydraulic Cylinder Model” on page 2-47

“Adjusting Constraints” on page 2-49

“Specifying Tuned Parameters” on page 2-54

“Running the Optimization” on page 2-55

“Changing Optimization Settings” on page 2-56

“Finding a Maximally Feasible Solution” on page 2-59

Introduction
This section discusses an example demonstrating further techniques for using
Simulink® Response Optimization™ software to directly tune Simulink®

models. It uses the model srotut2 to show how to constrain more than one
signal and tune multiple parameters. The physical system consists of a
hydraulic pump supplying pressure to a hydraulic cylinder. The cylinder
contains a piston, which extends and compresses a spring. This system is
modeled in the Simulink model srotut2. The system parameters that you
can adjust, or tune, to achieve the required design characteristics are the
cross-sectional area of the piston, Ac, and the maximum pump flow-rate, Qmax.

Design Requirements
Specifically, you will design a hydraulic system that extends a piston by
0.07 m while keeping the pressure from the pump below 12x105 Pa. The
specifications for the response of the piston position signal are:

• Maximum overshoot of 15%

• Rise time of 0.25 second

• Settle to within 10% of final value after 0.5 second

• Final value of 0.07 m
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The specifications for the response of the pump pressure signal are

• Lower bound of zero (Pressures below this value are not physically possible.)

• Upper bound of 12x105 Pa

Opening the Hydraulic Cylinder Model
The Simulink system srotut2 contains a block diagram representation of the
hydraulic system described in the preceding section. You can open the system
by typing srotut2 at the MATLAB® prompt.

Notice that the system contains two Signal Constraint blocks. These blocks
define constraints on the piston position and pump pressure signals. You can
constrain multiple responses including responses within subsystems of your
model. For each signal that you want to constrain, you need to attach a Signal
Constraint block. Within each Signal Constraint block, set constraint bounds
and/or reference signals for each signal. The tuned and uncertain parameters,
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along with optimization and simulation options are set for the whole system
within any one of the Signal Constraint blocks.
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Adjusting Constraints
In this section, you will adjust the signal constraints in the system.

Adjusting Pump Pressure Signal Constraints
Double-click the block labeled Signal Constraint, in the upper-right corner of
the model diagram. This block defines the constraints on the pump pressure
signal.

First, delete some constraint bound segments so that there is just a single
upper bound and a single lower bound. To do this, right-click the left-most
lower segment and select Delete from the menu.

Repeat for one additional lower segment and one upper segment. The figure
window should now look something like that in the following figure. Note that
the thick black constraint line is actually two constraint edges positioned
very close to each other.

2-49



2 Response Optimization Tutorial

Reposition the constraint bound segments using the Edit Design Requirement
dialog box. To move the lower constraint, right-click anywhere on the lower
constraint segment and select Edit from the menu. Within the Edit Design
Requirement dialog box, enter the start and end time of the constraint edge (0
and 1 respectively) as well as the amplitude of the constraint edge (since it
should lie flat, both ends have the same magnitude of 0).

The following figure shows the Edit Design Requirement dialog box with the
position settings for the lower constraint segment.
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Repeat for the upper constraint, moving the constraint edge so that it begins
at 0, ends at 1, and has a magnitude of 12e5. See the online documentation
for more information on the Edit Design Requirement dialog box.

The new constraints are positioned at the edge of the axes and cannot be
seen. To adjust the axes so that the constraints lie within the axes limits,
select Edit > Axes Properties in the Signal Constraint window. Change
the Y-limits to -5e5 and 15e5. The Signal Constraint window should now
look like that in the following figure.
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Adjusting Piston Position Signal Constraints
Double-click the block labeled Signal Constraint1, in the lower-right corner of
the model diagram. This block defines the constraints on the piston position
signal.

Reposition the constraint bound segments using the Desired Response dialog
box. Open the dialog box by selecting Goals > Desired Response from the
Signal Constraint window. Select Specify step response characteristics.
The list at the beginning of “Physical Modeling Example” on page 2-46
specifies the step response characteristics. Enter the information shown in
the following figure, and then click OK.
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These step response characteristics require that

• After 0.5 second, the signal must settle to within 10% of its final value
(between 0.063 m and 0.077 m).

• After 0.25 second, the signal must rise to 85% of the final value (or
approximately 0.06 m).

• The signal has a maximum overshoot of 15% (or up to approximately 0.08
m).

• The signal must have very little undershoot.

The constraint-bound segments should now look like those in the following
figure.
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See the online documentation for more information on step response settings.

Specifying Tuned Parameters
To optimize the signal responses in this example, you will tune two
parameters: the cross-sectional area of the piston, Ac, and the maximum
pump flow rate, Qmax. Although there are two constrained signals and two
tuned parameters, you could have any number of tuned parameters in your
response optimization.

You can specify tuned parameters within any Signal Constraint block in the
model; the tuned parameter settings are for the whole system, not just for a
particular optimized signal.

To specify the tuned parameters for this example, open any Signal Constraint
block in the model and select Optimization > Tuned Parameters. Within
the Tuned Parameters dialog box, click Add, and then select Ac and Qmax from
the list in the Add Parameters dialog box. Hold down the Ctrl key to select
multiple parameters from the list. Click OK to continue.
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In the Tuned Parameters dialog box, enter specifications for each tuned
parameter by selecting the parameter in the list on the left, and then entering
information such as initial guesses, minimum values, and maximum values
on the right. For Ac, enter 0 as a Minimum value since it does not make
sense for the cross-sectional area to be negative. Similarly, enter 0 as a
Minimum value for Qmax to avoid negative flow rates, which imply that the
flow reverses direction through the system.

See the online documentation for more information on tuned parameter
settings.

Running the Optimization
After adjusting the constraints and defining tuned parameters, start the
optimization by selecting Optimization > Start, or by clicking the Start
button below the menu bar in a Signal Constraint window.

In this case the optimization algorithm is not able to find a solution that
satisfies all the constraints, as seen in the Optimization Progress window in
the following figure.
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Changing Optimization Settings
When the optimization algorithm does not find a successful solution, you can
often find a better solution by changing some of the optimization settings and
running the optimization again. Useful things to try are

• Changing the Gradient type to Refined. This is more accurate for some
models.

• Increasing the tolerances.

• Using a different optimization algorithm.

For this example, change the gradient type to Refined by selecting
Optimization > Optimization Options in the Signal Constraint window,
and then selecting Refined as the Gradient type. Click OK to save the
changes and close the Options dialog box. See the online documentation for
more information on optimization settings.

2-56



Physical Modeling Example

Run the optimization again with these new settings. The optimization
algorithm should now find a feasible solution as shown in the following figure.

The Optimization Progress window shows the new optimized parameter
values of 0.0034 m2 for the cross-sectional area of the piston, and 0.0030 m3/s
for the pump flow rate. These values are also changed within the MATLAB
workspace.

The Signal Constraint windows also show that the optimized response signals
satisfy both sets of constraints. To see this more clearly, first remove all
response signals from the axes by selecting Plots > Clear Plots. Next, plot
the current response, based on the optimized parameter values, by selecting
Plots > Plot Current Response. The Signal Constraint windows should
now look like those in the following two figures for piston position and pump
pressure, respectively.
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Piston Position

Pump Pressure
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See Chapter 4, “Troubleshooting” for more advice on adjusting the response
optimization to achieve the desired results.

Finding a Maximally Feasible Solution
Although the results in the previous section satisfy the constraints, the
response signal for the piston position lies near the lower edge of the
constraint region. This is because the optimization stops as soon as a feasible
solution is found. To search for a solution that satisfies the constraints even
better, you can

1 Select Optimization > Optimization Options from a Signal Constraint
window to open the Options dialog box.

2 Select Look for maximally feasible solution. By selecting this option,
Simulink Response Optimization software will continue to search for an
optimal solution, after the initial solution is found.

3 Click OK to save the settings and close the Options dialog box.

4 Click the Start button to run the optimization again.

The optimization finds a new solution that lies further inside the constraint
region. The new optimized parameter values are 0.0032 m2 for the
cross-sectional area of the piston, and 0.0033 m3/s for the pump flow rate.
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Control Design Example Using Functions

In this section...

“Choosing Signals to Constrain” on page 3-2

“Creating an Optimization Project” on page 3-3

“Properties of a Response Optimization Project” on page 3-4

“Running the Optimization” on page 3-10

Choosing Signals to Constrain
This section illustrates an example which uses functions to optimize the
response of a signal in the Simulink® model srotut1. For a more detailed
description of these functions, refer to the Function Reference in the online
documentation.

Open the Simulink model srotut1 by typing:

srotut1

at the MATLAB® prompt. The model opens and should look like that in the
following figure.

The first step in the response optimization process is to choose which signals
in your Simulink model you want to constrain and to attach Signal Constraint
blocks to these signals. In srotut1 there is already a Signal Constraint block
attached to a signal. Refer to the online documentation for more information
on the Signal Constraint block.
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Creating an Optimization Project
After attaching Signal Constraint blocks to the appropriate signals within
your Simulink model, you need to create a Simulink® Response Optimization™
project. This project is an object that contains information about the response
optimization. There are two options for creating the project object:

• To create a default project with all project properties set to the default
settings, use the newsro function.

• To create a project based on the current response optimization settings in
the model, use the getsro function.

Creating a Default Project
Create a new project with default settings using the following command:

proj=newsro('srotut1',{'Kint'})

The first input to the newsro function is the model name. The second input
is a cell array of the tuned parameters. In this case Kint is the only tuned
parameter.

This returns the following object:

Name: 'srotut1'
Parameters: [1x1 ResponseOptimizer.Parameter]

OptimOptions: [1x1 ResponseOptimizer.OptimOptions]
Tests: [1x1 ResponseOptimizer.SimTest]
Model: 'srotut1'

Simulink Response Optimization Project.

Creating a Project Based on Current Response Optimization
Settings
Create a new project based on the current response optimization settings in
the model using the following command. This is useful when you previously
saved a project for the model and want to optimize this project at the command
line or when you have set the project up with the graphical interface and
would like to continue the analysis at the command line.
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proj2=getsro('srotut1')

This command returns a project object with the same properties as the object
returned with newsro, although these properties will possibly have different
current values. The model must already be open to use the getsro function.

Properties of a Response Optimization Project
Within the project object you can set characteristics of the tuned parameters,
specify uncertain parameters, position constraint bound segments, and set
options for the optimization and simulations.

Specifying Tuned Parameter Attributes
To specify bounds and initial guesses for the tuned parameters, first extract
the tuned parameters from the project object with the findpar function:

param=findpar(proj,'Kint')

This returns a tuned parameter object:

Name: 'Kint'
Value: 0

InitialGuess: 0
Minimum: -Inf
Maximum: Inf

TypicalValue: 0
ReferencedBy: {0x1 cell}
Description: ''

Tuned: 1

Tuned parameter.

Next, use dot notation to edit these properties to specify maximum values,
minimum values, initial guesses, etc. For example, to set the initial guess to
0.4 and the minimum value to 0, use the following commands:

param.InitialGuess=0.4;
param.Minimum=0

The new parameter settings are shown as follows:
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Name: 'Kint'
Value: 0

InitialGuess: 0.4000
Minimum: 0
Maximum: Inf

TypicalValue: 0
ReferencedBy: {0x1 cell}
Description: ''

Tuned: 1

Tuned parameter.

For more information on specifying tuned parameters, see the online
documentation.

Adjusting Signal Constraints
To define the constrain bound segments within which the optimized signal
response must lie, first extract a signal constraint object from the project,
using the findconstr function:

constr=findconstr(proj,'srotut1/Signal Constraint')

This function takes the project object and the location of a Signal Constraint
block in the model as inputs and creates the following signal constraint object:

ConstrEnable: 'on'
isFeasible: 1
CostEnable: 'off'

Enable: 'on'
Name: 'Signal Constraint'

SignalSize: [1 1]
LowerBoundX: [3x2 double]
LowerBoundY: [3x2 double]

LowerBoundWeight: [3x1 double]
UpperBoundX: [2x2 double]
UpperBoundY: [2x2 double]

UpperBoundWeight: [2x1 double]
ReferenceX: []
ReferenceY: []

ReferenceWeight: []
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Signal Constraint.

To move the constraints, edit the LowerBoundX, LowerBoundY, UpperBoundX,
and UpperBoundY matrices. These matrices specify the x and y positions of the
endpoints of each segment. For example:

To move the constraint bounds to the positions shown in the following figure,
use the following commands:

constr.LowerBoundX=[0 12;12 30;30 50];
constr.LowerBoundY=[0 0;0.9 0.9;0.99 0.99];
constr.UpperBoundX=[0 30;30 50];
constr.UpperBoundY=[1.1 1.1;1.01 1.01];
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For more information on constraint bound segments, see the online
documentation.

Setting Optimization Options
Before running the optimization, it is sometimes useful to change or set
some optimization options. These options define the algorithms and methods
Simulink Response Optimization software uses to optimize the signals. For
a list of all options and their uses, see “Tuning the Optimization Results” in
the online documentation or the documentation for the MATLAB function
optimset.

Get the current optimization options settings with the optimget function:

optimget(proj)

This returns a list of the options and their current values:

Algorithm: 'fmincon'
Display: 'iter'

GradientType: 'basic'
MaximallyFeasible: 0
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MaxIter: 100
TolCon: 1.0000e-003
TolFun: 1.0000e-003

TolX: 1.0000e-003
Restarts: 0

SearchMethod: []

Use the optimset function to change any values within the optimization
options object. For example, to change the tolerance on the parameter values,
TolX, to 1e-4 use the following command:

optimset(proj,'TolX',1e-4)

Setting Simulation Options
In addition to specifying optimization options, it is sometimes useful to specify
simulation options. These options define the solvers, simulation times, and
other settings that Simulink Response Optimization software uses when
simulating the models during the response optimization. For a list of all
options and their uses, see “Setting the Simulation Options” in the online
documentation or the documentation for the Simulink function simset.

Get the current simulation options settings with the simget function:

simget(proj)

This returns a list of the options and their current values:

AbsTol: 1.0000e-006
FixedStep: 'auto'

InitialStep: 'auto'
MaxStep: 'auto'
MinStep: 'auto'
RelTol: 1.0000e-003
Solver: 'ode45'

ZeroCross: 'on'
StartTime: '0.0'
StopTime: '50'
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To change values within the simulation options object, use the simset
function. For example, change the solver to ode23 with the following
command:

simset(proj,'Solver','ode23')

Specifying Uncertain Parameters
When some parameters in your model are not known exactly, but you do know
the nominal plant and the level of uncertainty surrounding this model, you
can include this uncertainty in your response optimization by specifying
uncertain parameters in your model.

In this example, assume that w0 varies between 0.8 and 1.2 while zeta varies
between 0.95 and 1.05. First, create a set of sample parameter values within
these ranges using the randunc function:

unc_rand=randunc(2,'w0',{0.8 1.2},'zeta',{0.95 1.05});

The randunc function creates combinations of parameter values based on the
endpoints of their uncertainty ranges. In addition, it creates several random
parameter value combinations. The first argument to the function specifies
the number of random parameter value combinations that the function
creates. The remaining input arguments specify the uncertain parameters
and the ranges over which they vary. This particular example creates two
random combinations of w0 and zeta values in addition to the combinations of
parameter values at the endpoints.

When you would rather specify uncertain parameter values on a grid, use
the gridunc function:

unc_grid=gridunc('w0',{0.8 0.9 1.0 1.1 1.2},'zeta',{0.95 1 1.05});

The gridunc function creates combinations of the given parameters at values
specified in the cell-arrays of parameter values.

For more information on creating sets of uncertain parameter value
combinations, see the reference pages for randunc and gridunc.

By default, when adjusting the tuned parameters, the response optimization
algorithm does not take responses based on these uncertain parameter
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values into account. To include an uncertain parameter combination in the
optimization, you must set its Optimized property to true.

For example, to include all the parameter combinations within unc_rand,
enter the following command:

unc_rand.Optimized(1:end)=true

After creating the set of uncertain parameter values, and choosing to include
some or all of them in the optimization, add these values to the project object
with the setunc function:

setunc(proj,unc_rand)

For more information on specifying uncertain parameter values, see the
online documentation.

Running the Optimization
To run the optimization for this project, enter

optimize(proj)

The results appear in the MATLAB Command Window after each iteration.
See the online documentation for more information on the optimization
results.

During the optimization, Simulink Response Optimization software changes
the tuned parameter values in the MATLAB workspace. The optimization
also displays the new, optimized parameter values after terminating. In this
example, the optimized value of Kint is 0.1539.
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Common Questions About Response Optimization
Where possible, Simulink® Response Optimization™ software provides visual
cues to help you formulate problems and inform you about the progress of
an optimization. However, you may run into problems when optimizing
the model responses. The following list of questions represent commonly
encountered problems with response optimization. Solutions, advice, and tips
are recommended for dealing with each question.

Questions

How do I quit an optimization and revert to my initial
parameter values?

• When using a Signal Constraint block in a Simulink® model, click the Stop
button or select Optimization > Stop in the Signal Constraint window
to stop the optimization. To revert to your initial parameter values, select
Edit > Undo Optimize Parameters.

• When using a SISO Design Task, the Start Optimization button becomes
a Stop Optimization button after the optimization has begun. To quit the
optimization, click the Stop Optimization button. To revert to the initial
parameter values, select Edit > Undo Optimize compensators from the
menu in the SISO Design Tool window.

Why don’t the responses and parameter values change at all?

• The optimization problem you formulated might be nonsmooth. This means
that small parameter changes have no effect on the amount by which
response signals satisfy or violate the constraints and only large changes
will make a difference. Try switching to a search-based algorithm such as
simplex search or pattern search. Alternatively, look for initial guesses
outside of the dead zone where parameter changes have no effect. If you
are directly optimizing the response of a Simulink model using a Signal
Constraint block, you could also try removing nonlinear blocks such as
the Quantizer or Dead Zone block.

• If you are using the Refined option for Gradient type with the gradient
descent algorithm, try the Basic option for Gradient type instead. The
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gradient model that the Refined option uses might be invalid for your
problem.

What to do if the optimization does not get close to an
acceptable solution?

• If you’re using gradient descent, the default algorithm, try the Refined
option for Gradient type. This option yields more accurate gradient
estimates when using variable-step solvers and can facilitate convergence.

• If you are using pattern search, check that you have specified appropriate
maximum and minimum values for all your tuned parameters or
compensator elements. The pattern search algorithm looks inside these
bounds for a solution. When they are set to their default values of Inf
and -Inf, the algorithm searches within ±100% of the initial values of the
parameters. In some cases this region is not large enough and changing the
maximum and minimum values can expand the search region.

• Your optimization problem might have local minima. Consider running one
of the search-based algorithms first to get closer to an acceptable solution.

• Reduce the number of tuned parameters and compensator elements
by removing from the Tuned parameters list (when using a Signal
Constraint block) or from the Compensators pane (when using a SISO
Design Task) those parameters that you know only mildly influence the
optimized responses. After you identify reasonable values for the key
parameters, add the fixed parameters back to the tunable list and restart
the optimization using these reasonable values as initial guesses.

Why does the optimization terminate before exceeding the
maximum number of iterations, with a solution that does not
satisfy all the constraints or design requirements?

• It might not be possible to achieve your specifications. Try relaxing the
constraints or design requirements that the response signals violate the
most. After you find an acceptable solution to the relaxed problem, tighten
some constraints again and restart the optimization.

• The optimization might have converged to a local minimum that is not a
feasible solution. Restart the optimization from a different initial guess
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and/or use one of the search-based methods to identify another local
minimum that satisfies the constraints.

What to do if the optimization drives the tuned compensator
elements and parameters to undesirable values?

• When a tuned compensator element or parameter is positive, or when its
value is physically constrained to a given range, enter the lower and upper
bounds (Minimum and Maximum) in one of the following:

- Tuned Parameters dialog box (from a Signal Constraint block)

- Compensators pane (in a SISO Design Task)

This information helps guide the optimization algorithm towards a
reasonable solution.

• In the Tuned Parameters dialog box (from a Signal Constraint block) or the
Compensators pane (in a SISO Design Task), specify initial guesses that
are within the range of desirable values.

• In the Compensators pane in a SISO Design Task, verify that no
integrators/differentiators are selected for optimization. Optimizing the
pole/zero location of integrators/differentiators can result in drastic changes
in the system gain and lead to undesirable values.

What to do if the optimization violates bounds on parameter
values?
The Gradient descent optimization algorithm fmincon violates the
parameter bounds when it cannot simultaneously satisfy the signal
constraints and the bounds. When this happens, try one of the following:

• Specify a different value for the parameter bound and restart the
optimization. A guideline is to adjust the bound by 1% of the typical value.

For example, for a parameter with a typical value of 1 and lower bound of
0, change the lower bound to 0.01.

• Relax the signal constraints and restart the optimization. This approach
results in a different solution path for the Gradient descent algorithm.
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• Restart the optimization immediately after it terminates by using the Start
optimization button in the Signal Constraint window. This approach
uses the previous optimization results as the starting point for the next
optimization cycle to refine the results.

• Use the following two-step approach to perform the optimization:

a Run an initial optimization to satisfy the signal constraints.

For example, run the optimization using the Simplex search algorithm.
This algorithm satisfies the signal constraints but does not support the
bounds on parameter values. The results obtained using this algorithm
provide the starting point for the optimization performed in the next
step. To learn more about this algorithm, see the fminsearch function
reference page in the Optimization Toolbox™ documentation.

b Reconfigure the optimization by selecting a different optimization
algorithm to satisfy both the signal constraints and the parameter
bounds.

For example, change the optimization algorithm to Gradient descent
and run the optimization again.

Tip If Genetic Algorithm and Direct Search Toolbox™ software is installed,
you can select the Pattern search optimization algorithm to optimize
the model response.

What to do if the optimization takes a long time to converge
even though it is close to a solution?

• In a Signal Constraint window, use the Stop button, or select
Optimization > Stop, to interrupt the optimization when you think the
current optimized response signals are acceptable.

When you use a SISO Design Task, click Stop Optimization in the
Optimization panel of the Response Optimization node in the Control
and Estimation Tools Manager, when you think the current optimized
response signals are acceptable.
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• If you use the gradient descent algorithm, try restarting the optimization.
Restarting resets the Hessian estimate and might speed up convergence.

• Increase the convergence tolerances in the Optimization Options dialog
to force earlier termination.

• Relax some of the constraints or design requirements to increase the size of
the feasibility region.

What to do if the response becomes unstable and does not
recover?
While the optimization formulation has explicit safeguards against unstable
or divergent response signals, the optimization can sometimes venture into
an unstable region where simulation results become erratic and gradient
methods fail to find a way back to the stable region. In these cases, you can
try one of the following solutions:

• Add or tighten the lower and upper bounds on compensator element and
parameter values. Instability often occurs when you allow some parameter
values to become too large.

• Use a search-based algorithm to find parameter values that stabilize the
response signals and then start the gradient-based algorithm using these
initial values.

• When optimizing responses in a SISO Design Task, you can try adding
additional design requirements that achieve the same or similar goal.
For example, in addition to a settling time design requirement on a step
response plot, you could add a settling time design requirement on a
root-locus plot that restricts the location of the real parts of the poles. By
adding overlapping design requirements in this way, you can force the
optimization to meet the requirements.

Why does the optimization stall?
When using a Signal Constraint block to directly optimize a Simulink model,
certain parameter combinations can make the simulation stall for models
with strong nonlinearities or frequent mode switching. In these cases, the
ODE solvers take smaller and smaller step sizes. Stalling can also occur
when the model’s ODEs become too stiff for some parameter combinations.
A symptom of this behavior is when the Simulink model status is Running
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and clicking the Stop button fails to interrupt the optimization. When this
happens, you can try one of the following solutions:

• Switch to a different ODE solver, especially one of the stiff solvers.

• Specify a minimum step size.

• Disable zero crossing detection if chattering is occurring.

• Tighten the lower and upper bounds on parameters that cause simulation
difficulties. In particular, eliminate regions of the parameter space where
some model assumptions are invalid and the model behavior can become
erratic.

How can I speed up the optimization?

• The optimization time is dominated by the time it takes to simulate
the model. When using a Signal Constraint block to directly optimize
a Simulink model, you can enable the Accelerator mode using
Simulation > Accelerator in the Simulink model window, to dramatically
reduce the optimization time.

Note The Rapid Accelerator mode in Simulink software is not supported
for speeding up the optimization. For more information, see the
Accelerating the Optimization in the Simulink Response Optimization
User’s Guide.

• The choice of ODE solver can also significantly affect the overall
optimization time. Use a stiff solver when the simulation takes many small
steps, and use a fixed-step solver when such solvers yield accurate enough
simulations for your model. (These solvers must be accurate in the entire
parameter search space.)

• Reduce the number of tuned compensator elements or parameters and
constrain their range to narrow the search space.

• When specifying parameter uncertainty (not available when optimizing
responses in a SISO Design Task), keep the number of sample values small
since the number of simulations grows exponentially with the number of
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samples. For example, a grid of 3 parameters with 10 sample values for
each parameter requires 103=1000 simulations per iteration.

How should I pick the start and stop time?

• When using a Signal Constraint block to directly optimize a Simulink
model: by default, the start and stop time are inherited from the Simulink
model. However, you can change them with the Simulation Options dialog
box. Choose a stop time that captures enough of the desired response’s
characteristics. When you want the response to settle to a final value, use
at least 10 to 20% of the simulation time for constraining the steady-state
response. This ensures the proper weighting of requirements on the final
value and overall stability.

• When using a SISO Design Task: Simulink Response Optimization
software automatically sets the model’s simulation start and stop time and
you cannot directly change them. By default, the simulation starts at 0 and
continues until the SISO Design Task determines that the dynamics of the
model have settled out. In addition, when the design requirements extend
beyond this point, the simulation continues to the extent of the design
requirements. Although you cannot directly adjust the start or stop time of
the simulation, you can adjust the design requirements to extend further in
time and thus force the simulation to continue to a certain point.

Should I worry about the scale of my responses and how
constraints and design requirements are discretized?
No. Simulink Response Optimization software automatically normalizes
constraints, design requirement and response data. Unlike its predecessor,
the Nonlinear Control Design Blockset software, it does not discretize the
constraints or design requirements.
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